Menu

Star on GitHub · 3.4k

CVE-2026-109383

7.4 · HIGH

undici is an HTTP client library for Node.js.

Published Oct 15, 2026nodejsCWE-295EPSS 0.18%

Overview

CVE-2026-109383 is a high-severity vulnerability affecting nodejs undici. It was published on October 15, 2026 and has a CVSS 3.1 base score of 7.4 (HIGH).

This vulnerability has a CVSS 3.1 base score of 7.4, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

undici is an HTTP client library for Node.js. In versions 4.0.0 through 6.29.0, 7.0.0 through 7.30.0, and 8.0.0 through 8.12.1, its Agent dispatcher passes its constructor options through a JSON-based deep clone before forwarding them to each per-origin pool, and because JSON cannot represent functions, a caller-supplied tls option containing a checkServerIdentity callback is silently dropped before it reaches the TLS layer. As a result, a TLS peer whose certificate a custom checkServerIdentity was written to reject, but which passes Node's default hostname and chain checks, is silently accepted. Because Agent is the default dispatcher behind request, fetch, and setGlobalDispatcher, this affects the path most applications use, and EnvHttpProxyAgent is affected on its direct and no-proxy routes as well, while only applications that pass a function-valued tls option such as a custom checkServerIdentity for certificate or public-key pinning are at risk. The issue is fixed in undici 6.29.1

Remediation

Check the references section for vendor advisories and patches from nodejs. Update undici to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
nodejsundici>= 4.0.0, < 6.29.1Affected

Frequently asked questions

What is CVE-2026-109383?

CVE-2026-109383 is a high-severity vulnerability affecting nodejs undici. It was published on October 15, 2026 and has a CVSS 3.1 base score of 7.4 (HIGH).

How severe is CVE-2026-109383?

This vulnerability has a CVSS 3.1 base score of 7.4, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-109383?

Check the references section for vendor advisories and patches from nodejs. Update undici to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-109383?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-109383 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
Watch the demo →