Menu

Star on GitHub · 3.4k

CVE-2026-110909

5.0 · MEDIUM

Wheels CLI through 4.1.0 does not verify that the local development server answering its HTTP requests belongs to the current project.

Published Oct 15, 2026CWE-923EPSS 0.13%

Overview

CVE-2026-110909 is a medium-severity vulnerability. It was published on October 15, 2026 and has a CVSS 3.1 base score of 5.0 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 5.0, rated MEDIUM. It requires local or adjacent network access to exploit. Some level of privileges is required for exploitation.

Technical description

Wheels CLI through 4.1.0 does not verify that the local development server answering its HTTP requests belongs to the current project. A process listening on a port targeted by the CLI can receive the project's reload password and code submitted through wheels reload or wheels console; console also probes common ports when the project server is down. Other commands can perform unintended state-changing operations against a different local application's server and database. Exploitation requires a process listening on a targeted local port and the developer running an affected command. This is fixed in 4.1.1, including changes to the CLI and application template.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2026-110909?

CVE-2026-110909 is a medium-severity vulnerability. It was published on October 15, 2026 and has a CVSS 3.1 base score of 5.0 (MEDIUM).

How severe is CVE-2026-110909?

This vulnerability has a CVSS 3.1 base score of 5.0, rated MEDIUM. It requires local or adjacent network access to exploit. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-110909?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-110909?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-110909 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2026

View all
Watch the demo →