Menu

Star on GitHub · 3.4k

CVE-2026-112400

7.5 · HIGH

Pillow is a Python imaging library.

Published Oct 19, 2026pythonCWE-400EPSS 0.59%

Overview

CVE-2026-112400 is a high-severity vulnerability affecting python pillow. It was published on October 19, 2026 and has a CVSS 3.1 base score of 7.5 (HIGH).

This vulnerability has a CVSS 3.1 base score of 7.5, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

Pillow is a Python imaging library. From 9.2.0 until 13.0.0, Pillow can retain a rejected GIF frame size after a decompression-bomb exception. In GifImageFile._seek, a crafted GIF can leave rejected dimensions stored after Image.DecompressionBombError; if an application catches that exception and continues processing the same image object, later seek or load operations allocate according to those dimensions and can exhaust memory, denying service. This issue is fixed in version 13.0.0.

Remediation

Check the references section for vendor advisories and patches from python. Update pillow to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
pythonpillow>= 9.2.0, < 13.0.0Affected

Frequently asked questions

What is CVE-2026-112400?

CVE-2026-112400 is a high-severity vulnerability affecting python pillow. It was published on October 19, 2026 and has a CVSS 3.1 base score of 7.5 (HIGH).

How severe is CVE-2026-112400?

This vulnerability has a CVSS 3.1 base score of 7.5, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-112400?

Check the references section for vendor advisories and patches from python. Update pillow to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-112400?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-112400 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
Watch the demo →