Menu

Star on GitHub · 3.4k

CVE-2026-114617

4.2 · MEDIUM

Authlib is a Python library which builds OAuth and OpenID Connect servers.

Published Oct 22, 2026authlibCWE-294EPSS 0.27%

Overview

CVE-2026-114617 is a medium-severity vulnerability affecting authlib authlib. It was published on October 22, 2026 and has a CVSS 3.1 base score of 4.2 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 4.2, rated MEDIUM. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

Authlib is a Python library which builds OAuth and OpenID Connect servers. Prior to 1.9.0, OpenIDMixin.parse_id_token() reads the nonce_supported decision from the untrusted ID token being validated and sets the expected nonce to null when that claim is the JSON boolean false. In implicit and hybrid relying parties, or applications that directly accept externally supplied ID tokens, an attacker with a captured validly signed token can bypass the nonce-to-session binding and replay the victim's token into an attacker-controlled session. Plain authorization code flow is not affected, and the token must still pass signature, issuer, and audience validation. OpenIDMixin.parse_id_token() trusts nonce_supported in both authlib/integrations/base_client/sync_openid.py and authlib/integrations/base_client/async_openid.py to disable the expected nonce. This issue is fixed in version 1.9.0.

Remediation

Check the references section for vendor advisories and patches from authlib. Update authlib to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
authlibauthlib>= 0, < 1.9.0Affected

Frequently asked questions

What is CVE-2026-114617?

CVE-2026-114617 is a medium-severity vulnerability affecting authlib authlib. It was published on October 22, 2026 and has a CVSS 3.1 base score of 4.2 (MEDIUM).

How severe is CVE-2026-114617?

This vulnerability has a CVSS 3.1 base score of 4.2, rated MEDIUM. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-114617?

Check the references section for vendor advisories and patches from authlib. Update authlib to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-114617?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-114617 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2026

View all
Watch the demo →