Menu

Star on GitHub · 3.4k

CVE-2026-114619

4.6 · MEDIUM

Authlib is a Python library which builds OAuth and OpenID Connect servers.

Published Oct 22, 2026authlibCWE-863EPSS 0.16%

Overview

CVE-2026-114619 is a medium-severity vulnerability affecting authlib authlib. It was published on October 22, 2026 and has a CVSS 3.1 base score of 4.6 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 4.6, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

Authlib is a Python library which builds OAuth and OpenID Connect servers. Prior to 1.9.0, OpenIDImplicitGrant.validate_authorization_request() checks the client-controlled raw request.payload.scope for openid after the parent grant has filtered allowed scopes into request.scope. A registered client permitted an ID token response type but not the openid scope can add openid to the request, obtain user consent, and receive a signed ID token containing the user's subject and allowed profile claims. Authorization code flow and deployments that allow openid for every client permitted an ID token response are not affected. In authlib/oidc/core/grants/implicit.py, OpenIDImplicitGrant.validate_authorization_request() checks request.payload.scope instead of the filtered request.scope. This issue is fixed in version 1.9.0.

Remediation

Check the references section for vendor advisories and patches from authlib. Update authlib to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
authlibauthlib>= 0, < 1.9.0Affected

Frequently asked questions

What is CVE-2026-114619?

CVE-2026-114619 is a medium-severity vulnerability affecting authlib authlib. It was published on October 22, 2026 and has a CVSS 3.1 base score of 4.6 (MEDIUM).

How severe is CVE-2026-114619?

This vulnerability has a CVSS 3.1 base score of 4.6, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-114619?

Check the references section for vendor advisories and patches from authlib. Update authlib to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-114619?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-114619 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2026

View all
Watch the demo →