Menu

Star on GitHub · 3.4k

CVE-2026-18061

5.9 · MEDIUM

Improper restriction of XML external entity references in the RemoteQueryCachePlugin in AWS Advanced JDBC Wrapper 3.3.0 through 4.2.0 might allow an actor with write access to the shared cache infr…

Published Sep 11, 2026amazonCWE-611EPSS 0.46%

Overview

CVE-2026-18061 is a medium-severity vulnerability affecting amazon advanced_jdbc_wrapper. It was published on September 11, 2026 and has a CVSS 3.1 base score of 5.9 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 5.9, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

Improper restriction of XML external entity references in the RemoteQueryCachePlugin in AWS Advanced JDBC Wrapper 3.3.0 through 4.2.0 might allow an actor with write access to the shared cache infrastructure to disclose sensitive files from application hosts that read cached query results, including stored database and IAM role credentials, via crafted XML data in a cached column value.

To remediate this issue, users should upgrade to version 4.3.0 or later.

Remediation

Check the references section for vendor advisories and patches from amazon. Update advanced_jdbc_wrapper to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
amazonadvanced_jdbc_wrapper>= 3.3.0, < 4.3.0Affected

Frequently asked questions

What is CVE-2026-18061?

CVE-2026-18061 is a medium-severity vulnerability affecting amazon advanced_jdbc_wrapper. It was published on September 11, 2026 and has a CVSS 3.1 base score of 5.9 (MEDIUM).

How severe is CVE-2026-18061?

This vulnerability has a CVSS 3.1 base score of 5.9, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-18061?

Check the references section for vendor advisories and patches from amazon. Update advanced_jdbc_wrapper to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-18061?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-18061 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2026

View all
Watch the demo →