Menu

Star on GitHub · 3.4k

CVE-2026-19118

7.5 · HIGH

A time-of-check time-of-use race condition vulnerability was identified in GitHub Enterprise Server that allowed remote code execution.

Published Sep 1, 2026githubCWE-367EPSS 0.91%

Overview

CVE-2026-19118 is a high-severity vulnerability affecting github enterprise_server. It was published on September 1, 2026 and has a CVSS 3.1 base score of 7.5 (HIGH).

This vulnerability has a CVSS 3.1 base score of 7.5, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

A time-of-check time-of-use race condition vulnerability was identified in GitHub Enterprise Server that allowed remote code execution. Exploitation required an authenticated user with write access to a repository and precise timing of concurrent upload requests. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.22 and was fixed in versions 3.17.20, 3.18.14, 3.19.11, 3.20.7, and 3.21.5. This vulnerability was reported via the GitHub Bug Bounty program.

Remediation

Check the references section for vendor advisories and patches from github. Update enterprise_server to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
githubenterprise_server>= 0, < 3.17.20Affected

Frequently asked questions

What is CVE-2026-19118?

CVE-2026-19118 is a high-severity vulnerability affecting github enterprise_server. It was published on September 1, 2026 and has a CVSS 3.1 base score of 7.5 (HIGH).

How severe is CVE-2026-19118?

This vulnerability has a CVSS 3.1 base score of 7.5, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-19118?

Check the references section for vendor advisories and patches from github. Update enterprise_server to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-19118?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-19118 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
Watch the demo →