Menu

Star on GitHub · 3.4k

CVE-2026-29174

8.8 · HIGH

Craft Commerce is an ecommerce platform for Craft CMS.

Published Mar 10, 2026craftcmsCWE-89EPSS 0.46%

Overview

CVE-2026-29174 is a high-severity vulnerability affecting craftcms craft_commerce. It was published on March 10, 2026 and has a CVSS 3.1 base score of 8.8 (HIGH).

This vulnerability has a CVSS 3.1 base score of 8.8, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

Craft Commerce is an ecommerce platform for Craft CMS. Prior to 5.5.3, Craft Commerce is vulnerable to SQL Injection in the inventory levels table data endpoint. The sort[0][direction] and sort[0][sortField] parameters are concatenated directly into an addOrderBy() clause without any validation or sanitization. An authenticated attacker with access to the Commerce Inventory section can inject arbitrary SQL queries, potentially leading to a full database compromise. This vulnerability is fixed in 5.5.3.

Remediation

Check the references section for vendor advisories and patches from craftcms. Update craft_commerce to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
craftcmscraft_commerce>= 5.0.0, < 5.5.3Affected

Frequently asked questions

What is CVE-2026-29174?

CVE-2026-29174 is a high-severity vulnerability affecting craftcms craft_commerce. It was published on March 10, 2026 and has a CVSS 3.1 base score of 8.8 (HIGH).

How severe is CVE-2026-29174?

This vulnerability has a CVSS 3.1 base score of 8.8, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-29174?

Check the references section for vendor advisories and patches from craftcms. Update craft_commerce to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-29174?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-29174 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
Watch the demo →