Menu

Star on GitHub · 3.4k

CVE-2026-30868

6.3 · MEDIUM

OPNsense is a FreeBSD based firewall and routing platform.

Published Mar 11, 2026opnsenseCWE-352EPSS 0.15%

Overview

CVE-2026-30868 is a medium-severity vulnerability affecting opnsense opnsense. It was published on March 11, 2026 and has a CVSS 3.1 base score of 6.3 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 6.3, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

OPNsense is a FreeBSD based firewall and routing platform. Prior to 26.1.4, multiple OPNsense MVC API endpoints perform state‑changing operations but are accessible via HTTP GET requests without CSRF protection. The framework CSRF validation in ApiControllerBase only applies to POST/PUT/DELETE methods, allowing authenticated GET requests to bypass CSRF verification. As a result, a malicious website can trigger privileged backend actions when visited by an authenticated user, causing unintended service reloads and configuration changes through configd. This results in an authenticated Cross‑Site Request Forgery vulnerability allowing unauthorized system state changes. This vulnerability is fixed in 26.1.4.

Remediation

Check the references section for vendor advisories and patches from opnsense. Update opnsense to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
opnsenseopnsense>= 0, < 26.1.4Affected

Frequently asked questions

What is CVE-2026-30868?

CVE-2026-30868 is a medium-severity vulnerability affecting opnsense opnsense. It was published on March 11, 2026 and has a CVSS 3.1 base score of 6.3 (MEDIUM).

How severe is CVE-2026-30868?

This vulnerability has a CVSS 3.1 base score of 6.3, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-30868?

Check the references section for vendor advisories and patches from opnsense. Update opnsense to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-30868?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-30868 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2026

View all
Watch the demo →