Menu

Star on GitHub · 3.4k

CVE-2026-31834

7.2 · HIGH

Umbraco is an ASP.NET CMS.

Published Mar 10, 2026umbracoCWE-269EPSS 0.36%

Overview

CVE-2026-31834 is a high-severity vulnerability affecting umbraco umbraco_cms. It was published on March 10, 2026 and has a CVSS 3.1 base score of 7.2 (HIGH).

This vulnerability has a CVSS 3.1 base score of 7.2, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

Umbraco is an ASP.NET CMS. From 15.3.1 to before 16.5.1 and 17.2.2, A privilege escalation vulnerability has been identified in Umbraco CMS. Under certain conditions, authenticated backoffice users with permission to manage users, may be able to elevate their privileges due to insufficient authorization enforcement when modifying user group memberships. The affected functionality does not properly validate whether a user has sufficient privileges to assign highly privileged roles. This vulnerability is fixed in 16.5.1 and 17.2.2.

Remediation

Check the references section for vendor advisories and patches from umbraco. Update umbraco_cms to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
umbracoumbraco_cms>= 15.3.1, < 16.5.1Affected

Frequently asked questions

What is CVE-2026-31834?

CVE-2026-31834 is a high-severity vulnerability affecting umbraco umbraco_cms. It was published on March 10, 2026 and has a CVSS 3.1 base score of 7.2 (HIGH).

How severe is CVE-2026-31834?

This vulnerability has a CVSS 3.1 base score of 7.2, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-31834?

Check the references section for vendor advisories and patches from umbraco. Update umbraco_cms to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-31834?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-31834 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
Watch the demo →