Menu

Star on GitHub · 3.4k

CVE-2026-32942

8.1 · HIGH

PJSIP is a free and open source multimedia communication library written in C.

Published Mar 20, 2026pjsipCWE-416EPSS 0.33%

Overview

CVE-2026-32942 is a high-severity vulnerability affecting pjsip pjsip. It was published on March 20, 2026 and has a CVSS 3.1 base score of 8.1 (HIGH).

This vulnerability has a CVSS 3.1 base score of 8.1, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

PJSIP is a free and open source multimedia communication library written in C. Versions 2.16 and below contain a heap use-after-free vulnerability in the ICE session that occurs when there are race conditions between session destruction and the callbacks. This issue has been fixed in version 2.17.

Remediation

Check the references section for vendor advisories and patches from pjsip. Update pjsip to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
pjsippjsip>= 0, < 2.17Affected

Frequently asked questions

What is CVE-2026-32942?

CVE-2026-32942 is a high-severity vulnerability affecting pjsip pjsip. It was published on March 20, 2026 and has a CVSS 3.1 base score of 8.1 (HIGH).

How severe is CVE-2026-32942?

This vulnerability has a CVSS 3.1 base score of 8.1, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-32942?

Check the references section for vendor advisories and patches from pjsip. Update pjsip to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-32942?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-32942 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
Watch the demo →