Menu

Star on GitHub · 3.4k

CVE-2026-34070

7.5 · HIGH

LangChain is a framework for building agents and LLM-powered applications.

Published Mar 31, 2026langchainCWE-22EPSS 1.44%

Overview

CVE-2026-34070 is a high-severity vulnerability affecting langchain langchain_core. It was published on March 31, 2026 and has a CVSS 3.1 base score of 7.5 (HIGH).

This vulnerability has a CVSS 3.1 base score of 7.5, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

LangChain is a framework for building agents and LLM-powered applications. Prior to version 1.2.22, multiple functions in langchain_core.prompts.loading read files from paths embedded in deserialized config dicts without validating against directory traversal or absolute path injection. When an application passes user-influenced prompt configurations to load_prompt() or load_prompt_from_config(), an attacker can read arbitrary files on the host filesystem, constrained only by file-extension checks (.txt for templates, .json/.yaml for examples). This issue has been patched in version 1.2.22.

Remediation

Check the references section for vendor advisories and patches from langchain. Update langchain_core to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
langchainlangchain_core>= 0, < 1.2.22Affected

Frequently asked questions

What is CVE-2026-34070?

CVE-2026-34070 is a high-severity vulnerability affecting langchain langchain_core. It was published on March 31, 2026 and has a CVSS 3.1 base score of 7.5 (HIGH).

How severe is CVE-2026-34070?

This vulnerability has a CVSS 3.1 base score of 7.5, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-34070?

Check the references section for vendor advisories and patches from langchain. Update langchain_core to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-34070?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-34070 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
Watch the demo →