Menu

Star on GitHub · 3.4k

CVE-2026-34237

6.1 · MEDIUM

MCP Java SDK is the official Java SDK for Model Context Protocol servers and clients.

Published Mar 31, 2026lfprojectsCWE-942EPSS 0.23%

Overview

CVE-2026-34237 is a medium-severity vulnerability affecting lfprojects mcp_java_sdk. It was published on March 31, 2026 and has a CVSS 3.1 base score of 6.1 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 6.1, rated MEDIUM. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

MCP Java SDK is the official Java SDK for Model Context Protocol servers and clients. Prior to versions 0.83.0, 1.0.1, and 1.1.1, there is a hardcoded wildcard CORS vulnerability. This issue has been patched in versions 0.83.0, 1.0.1, and 1.1.1.

Remediation

Check the references section for vendor advisories and patches from lfprojects. Update mcp_java_sdk to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
lfprojectsmcp_java_sdk>= 0, < 1.0.1Affected

Frequently asked questions

What is CVE-2026-34237?

CVE-2026-34237 is a medium-severity vulnerability affecting lfprojects mcp_java_sdk. It was published on March 31, 2026 and has a CVSS 3.1 base score of 6.1 (MEDIUM).

How severe is CVE-2026-34237?

This vulnerability has a CVSS 3.1 base score of 6.1, rated MEDIUM. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-34237?

Check the references section for vendor advisories and patches from lfprojects. Update mcp_java_sdk to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-34237?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-34237 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2026

View all
Watch the demo →