Menu

Star on GitHub · 3.4k

CVE-2026-34359

7.4 · HIGH

HAPI FHIR is a complete implementation of the HL7 FHIR standard for healthcare interoperability in Java.

Published Mar 31, 2026hapifhirCWE-346EPSS 0.16%

Overview

CVE-2026-34359 is a high-severity vulnerability affecting hapifhir hl7_fhir_core. It was published on March 31, 2026 and has a CVSS 3.1 base score of 7.4 (HIGH).

This vulnerability has a CVSS 3.1 base score of 7.4, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

HAPI FHIR is a complete implementation of the HL7 FHIR standard for healthcare interoperability in Java. Prior to version 6.9.4, ManagedWebAccessUtils.getServer() uses String.startsWith() to match request URLs against configured server URLs for authentication credential dispatch. Because configured server URLs (e.g., http://tx.fhir.org) lack a trailing slash or host boundary check, an attacker-controlled domain like http://tx.fhir.org.attacker.com matches the prefix and receives Bearer tokens, Basic auth credentials, or API keys when the HTTP client follows a redirect to that domain. This issue has been patched in version 6.9.4.

Remediation

Check the references section for vendor advisories and patches from hapifhir. Update hl7_fhir_core to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
hapifhirhl7_fhir_core>= 0, < 6.9.4Affected

Frequently asked questions

What is CVE-2026-34359?

CVE-2026-34359 is a high-severity vulnerability affecting hapifhir hl7_fhir_core. It was published on March 31, 2026 and has a CVSS 3.1 base score of 7.4 (HIGH).

How severe is CVE-2026-34359?

This vulnerability has a CVSS 3.1 base score of 7.4, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-34359?

Check the references section for vendor advisories and patches from hapifhir. Update hl7_fhir_core to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-34359?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-34359 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
Watch the demo →