Menu

Star on GitHub · 3.4k

CVE-2026-34455

8.8 · HIGH

Hi.Events is an open-source event management and ticket selling platform.

Published Apr 1, 2026hi.eventsCWE-89EPSS 0.36%

Overview

CVE-2026-34455 is a high-severity vulnerability affecting hi.events hi.events. It was published on April 1, 2026 and has a CVSS 3.1 base score of 8.8 (HIGH).

This vulnerability has a CVSS 3.1 base score of 8.8, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

Hi.Events is an open-source event management and ticket selling platform. From version 0.8.0-beta.1 to before version 1.7.1-beta, multiple repository classes pass the user-supplied sort_by query parameter directly to Eloquent's orderBy() without validation, enabling SQL injection. The application uses PostgreSQL which supports stacked queries. This issue has been patched in version 1.7.1-beta.

Remediation

Check the references section for vendor advisories and patches from hi.events. Update hi.events to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
hi.eventshi.events>= 0.8.0, < 1.7.1Affected

Frequently asked questions

What is CVE-2026-34455?

CVE-2026-34455 is a high-severity vulnerability affecting hi.events hi.events. It was published on April 1, 2026 and has a CVSS 3.1 base score of 8.8 (HIGH).

How severe is CVE-2026-34455?

This vulnerability has a CVSS 3.1 base score of 8.8, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-34455?

Check the references section for vendor advisories and patches from hi.events. Update hi.events to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-34455?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-34455 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
Watch the demo →