Menu

Star on GitHub · 3.4k

CVE-2026-35197

6.6 · MEDIUM

dye is a portable and respectful color library for shell scripts.

Published Apr 6, 2026mattiebeeCWE-94EPSS 0.29%

Overview

CVE-2026-35197 is a medium-severity vulnerability affecting mattiebee dye. It was published on April 6, 2026 and has a CVSS 3.1 base score of 6.6 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 6.6, rated MEDIUM. It requires local or adjacent network access to exploit. Some level of privileges is required for exploitation.

Technical description

dye is a portable and respectful color library for shell scripts. Prior to 1.1.1, certain dye template expressions would result in execution of arbitrary code. This issue was discovered and fixed by dye's author, and is not known to be exploited. This vulnerability is fixed in 1.1.1.

Remediation

Check the references section for vendor advisories and patches from mattiebee. Update dye to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus

Frequently asked questions

What is CVE-2026-35197?

CVE-2026-35197 is a medium-severity vulnerability affecting mattiebee dye. It was published on April 6, 2026 and has a CVSS 3.1 base score of 6.6 (MEDIUM).

How severe is CVE-2026-35197?

This vulnerability has a CVSS 3.1 base score of 6.6, rated MEDIUM. It requires local or adjacent network access to exploit. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-35197?

Check the references section for vendor advisories and patches from mattiebee. Update dye to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-35197?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-35197 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2026

View all
Watch the demo →