Menu

Star on GitHub · 3.4k

CVE-2026-40178

5.9 · MEDIUM

ajenti.plugin.core defines all necessary core elements to allow Ajenti to run properly.

Published Apr 10, 2026ajentiCWE-287EPSS 0.23%

Overview

CVE-2026-40178 is a medium-severity vulnerability affecting ajenti ajenti_plugin_core. It was published on April 10, 2026 and has a CVSS 3.1 base score of 5.9 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 5.9, rated MEDIUM. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

ajenti.plugin.core defines all necessary core elements to allow Ajenti to run properly. Prior to 0.112, if the 2FA was activated, it was possible during a short moment after the authentication of an user to bypass its authentication. This vulnerability is fixed in 0.112.

Remediation

Check the references section for vendor advisories and patches from ajenti. Update ajenti_plugin_core to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
ajentiajenti_plugin_core>= 0, < 0.112Affected

Frequently asked questions

What is CVE-2026-40178?

CVE-2026-40178 is a medium-severity vulnerability affecting ajenti ajenti_plugin_core. It was published on April 10, 2026 and has a CVSS 3.1 base score of 5.9 (MEDIUM).

How severe is CVE-2026-40178?

This vulnerability has a CVSS 3.1 base score of 5.9, rated MEDIUM. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-40178?

Check the references section for vendor advisories and patches from ajenti. Update ajenti_plugin_core to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-40178?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-40178 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2026

View all
Watch the demo →