Menu

Star on GitHub · 3.4k

CVE-2026-40968

4.2 · MEDIUM

When an authenticated user is denied access to a gRPC method, their authenticated identity remains bound to the gRPC worker thread and can be inherited by a subsequent unauthenticated request on th…

Published Apr 28, 2026vmwareCWE-653EPSS 0.17%

Overview

CVE-2026-40968 is a medium-severity vulnerability affecting vmware spring_grpc. It was published on April 28, 2026 and has a CVSS 3.1 base score of 4.2 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 4.2, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

When an authenticated user is denied access to a gRPC method, their authenticated identity remains bound to the gRPC worker thread and can be inherited by a subsequent unauthenticated request on the same thread. This may allow the subsequent user to gain escalated permissions.

Affected versions:

Spring gRPC: 1.0.0 - 1.0.2 (fixed in 1.0.3). Older, unsupported versions are also affected.

Remediation

Check the references section for vendor advisories and patches from vmware. Update spring_grpc to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
vmwarespring_grpc>= 0, < 1.0.3Affected

Frequently asked questions

What is CVE-2026-40968?

CVE-2026-40968 is a medium-severity vulnerability affecting vmware spring_grpc. It was published on April 28, 2026 and has a CVSS 3.1 base score of 4.2 (MEDIUM).

How severe is CVE-2026-40968?

This vulnerability has a CVSS 3.1 base score of 4.2, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-40968?

Check the references section for vendor advisories and patches from vmware. Update spring_grpc to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-40968?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-40968 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2026

View all
Watch the demo →