Menu

Star on GitHub · 3.4k

CVE-2026-42189

7.5 · HIGH

Russh is a Rust SSH client & server library.

Published May 8, 2026russh_projectCWE-770EPSS 0.48%

Overview

CVE-2026-42189 is a high-severity vulnerability affecting russh_project russh. It was published on May 8, 2026 and has a CVSS 3.1 base score of 7.5 (HIGH).

This vulnerability has a CVSS 3.1 base score of 7.5, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

Russh is a Rust SSH client & server library. Prior to version 0.60.1, a pre-authentication denial-of-service vulnerability exists in the server's keyboard-interactive authentication handler. A malicious client can crash any russh-based server that implements keyboard-interactive auth (e.g., for 2FA/TOTP) with a single malformed packet, requiring no credentials. This issue has been patched in version 0.60.1.

Remediation

Check the references section for vendor advisories and patches from russh_project. Update russh to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
russh_projectrussh>= 0, < 0.60.1Affected
warpgate_projectwarpgate>= 0, < 0.23.1Affected

Frequently asked questions

What is CVE-2026-42189?

CVE-2026-42189 is a high-severity vulnerability affecting russh_project russh. It was published on May 8, 2026 and has a CVSS 3.1 base score of 7.5 (HIGH).

How severe is CVE-2026-42189?

This vulnerability has a CVSS 3.1 base score of 7.5, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-42189?

Check the references section for vendor advisories and patches from russh_project. Update russh to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-42189?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-42189 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
Watch the demo →