Menu

Star on GitHub · 3.4k

CVE-2026-42528

4.3 · MEDIUM

A memory calculation bug in mod_dav in Apache httpd 2.4.67 and earlier allows an attacker with permission to create WebDAV locks to crash server child processes.

Published Oct 1, 2026apacheCWE-789EPSS 0.40%

Overview

CVE-2026-42528 is a medium-severity vulnerability affecting apache http_server. It was published on October 1, 2026 and has a CVSS 3.1 base score of 4.3 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 4.3, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

A memory calculation bug in mod_dav in Apache httpd 2.4.67 and earlier allows an attacker with permission to create WebDAV locks to crash server child processes.

Users are recommended to upgrade to version 2.4.69, which fixes this issue

Remediation

Check the references section for vendor advisories and patches from apache. Update http_server to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
apachehttp_server>= 2.4.0, < 2.4.69Affected

Frequently asked questions

What is CVE-2026-42528?

CVE-2026-42528 is a medium-severity vulnerability affecting apache http_server. It was published on October 1, 2026 and has a CVSS 3.1 base score of 4.3 (MEDIUM).

How severe is CVE-2026-42528?

This vulnerability has a CVSS 3.1 base score of 4.3, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-42528?

Check the references section for vendor advisories and patches from apache. Update http_server to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-42528?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-42528 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2026

View all
Watch the demo →