Menu

Star on GitHub · 3.4k

CVE-2026-43910

8.2 · HIGH

Appium Java Client is the Java language binding for writing Appium tests that conform to the W3C WebDriver protocol.

Published Jul 28, 2026appiumCWE-441EPSS 0.43%

Overview

CVE-2026-43910 is a high-severity vulnerability affecting appium java-client. It was published on July 28, 2026 and has a CVSS 3.1 base score of 8.2 (HIGH).

This vulnerability has a CVSS 3.1 base score of 8.2, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

Appium Java Client is the Java language binding for writing Appium tests that conform to the W3C WebDriver protocol. From 8.2.1 until 10.1.1, when directConnect(true) is enabled, AppiumCommandExecutor.setDirectConnect() reads the directConnectHost, directConnectPort, and directConnectPath fields from the server's NEW_SESSION response and rebuilds the client's server URL from them, validating only that the protocol is https, with no host allowlist or IP validation; a rogue or compromised server can therefore redirect all subsequent session traffic to an arbitrary destination, enabling full interception of session traffic and a server-side request forgery pivot to internal hosts, including cloud metadata (IMDS) credential theft. This vulnerability is fixed in 10.1.1.

Remediation

Check the references section for vendor advisories and patches from appium. Update java-client to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
appiumjava-client>= 8.2.1, < 10.1.1Affected

Frequently asked questions

What is CVE-2026-43910?

CVE-2026-43910 is a high-severity vulnerability affecting appium java-client. It was published on July 28, 2026 and has a CVSS 3.1 base score of 8.2 (HIGH).

How severe is CVE-2026-43910?

This vulnerability has a CVSS 3.1 base score of 8.2, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-43910?

Check the references section for vendor advisories and patches from appium. Update java-client to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-43910?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-43910 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
Watch the demo →