Menu

Star on GitHub · 3.4k

CVE-2026-44235

6.5 · MEDIUM

rabbitmq-c is a C-language AMQP client library for RabbitMQ.

Published Sep 17, 2026CWE-125EPSS 0.31%

Overview

CVE-2026-44235 is a medium-severity vulnerability. It was published on September 17, 2026 and has a CVSS 3.1 base score of 6.5 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 6.5, rated MEDIUM. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

rabbitmq-c is a C-language AMQP client library for RabbitMQ. Prior to 0.16.0, a malicious AMQP server can send an undersized HEADER or METHOD frame during client login and cause unsigned size_t underflow in amqp_handle_input() in librabbitmq/amqp_connection.c. The parser subtracts HEADER_SIZE, fixed per-frame fields, and FOOTER_SIZE from state->target_size without first checking the minimum frame length. The wrapped encoded.len value is passed through amqp_decode_properties() to amqp_decode_table_internal(), where it defeats bounds checks and causes an out-of-bounds read and process crash. An on-path attacker can also trigger the issue when AMQP traffic is not protected by TLS with certificate validation. The demonstrated impact is denial of service, with no reliable memory disclosure or code execution shown. This issue is fixed in version 0.16.0.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2026-44235?

CVE-2026-44235 is a medium-severity vulnerability. It was published on September 17, 2026 and has a CVSS 3.1 base score of 6.5 (MEDIUM).

How severe is CVE-2026-44235?

This vulnerability has a CVSS 3.1 base score of 6.5, rated MEDIUM. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-44235?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-44235?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-44235 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2026

View all
Watch the demo →