Menu

Star on GitHub · 3.4k

CVE-2026-45205

5.3 · MEDIUM

Uncontrolled Recursion vulnerability in Apache Commons.

Published May 14, 2026apacheCWE-674EPSS 0.47%

Overview

CVE-2026-45205 is a medium-severity vulnerability affecting apache commons_configuration. It was published on May 14, 2026 and has a CVSS 3.1 base score of 5.3 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 5.3, rated MEDIUM. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

Uncontrolled Recursion vulnerability in Apache Commons.

When processing an untrusted configuration file, Commons Configuration will throw a StackOverflowError for YAML input with cycles.

This issue affects Apache Commons: from 2.2 before 2.15.0.

Users are recommended to upgrade to version 2.15.0, which fixes the issue.

Remediation

Check the references section for vendor advisories and patches from apache. Update commons_configuration to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
apachecommons_configuration>= 2.2, < 2.15.0Affected

Frequently asked questions

What is CVE-2026-45205?

CVE-2026-45205 is a medium-severity vulnerability affecting apache commons_configuration. It was published on May 14, 2026 and has a CVSS 3.1 base score of 5.3 (MEDIUM).

How severe is CVE-2026-45205?

This vulnerability has a CVSS 3.1 base score of 5.3, rated MEDIUM. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-45205?

Check the references section for vendor advisories and patches from apache. Update commons_configuration to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-45205?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-45205 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2026

View all
Watch the demo →