Menu

Star on GitHub · 3.4k

CVE-2026-4800

8.1 · HIGH

The fix for CVE-2021-23337 added validation for the variable option in _.template but did not apply the same validation to options.imports key names, and both paths flow into the same Function() co…

Published Mar 31, 2026lodashCWE-94EPSS 2.81%

Overview

CVE-2026-4800 is a high-severity vulnerability affecting lodash lodash. It was published on March 31, 2026 and has a CVSS 3.1 base score of 8.1 (HIGH).

This vulnerability has a CVSS 3.1 base score of 8.1, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

The fix for CVE-2021-23337 added validation for the variable option in _.template but did not apply the same validation to options.imports key names, and both paths flow into the same Function() constructor sink. When an application passes untrusted input as options.imports key names, an attacker can inject default-parameter expressions that execute arbitrary code at template compilation time. Additionally, _.template uses assignInWith to merge imports, which enumerates inherited properties via for..in, so if Object.prototype has been polluted by another vector the polluted keys are copied into the imports object and passed to Function(). The issue is fixed in 4.18.1 for lodash, lodash-es, lodash-amd, and lodash.template. As a workaround, do not pass untrusted input as key names in options.imports; use only developer-controlled, static key names.

Remediation

Check the references section for vendor advisories and patches from lodash. Update lodash to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
lodashlodash>= 4.0.0, < 4.18.0Affected
lodashlodash-amd>= 4.0.0, < 4.18.0Affected
lodashlodash-es>= 4.0.0, < 4.18.0Affected
lodashlodash.template>= 4.0.0, < 4.18.0Affected

Frequently asked questions

What is CVE-2026-4800?

CVE-2026-4800 is a high-severity vulnerability affecting lodash lodash. It was published on March 31, 2026 and has a CVSS 3.1 base score of 8.1 (HIGH).

How severe is CVE-2026-4800?

This vulnerability has a CVSS 3.1 base score of 8.1, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-4800?

Check the references section for vendor advisories and patches from lodash. Update lodash to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-4800?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-4800 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
Watch the demo →