Menu

Star on GitHub · 3.4k

CVE-2026-52769

8.3 · HIGH

YesWiki is a wiki system written in PHP.

Published Sep 5, 2026CWE-918EPSS 0.49%

Overview

CVE-2026-52769 is a high-severity vulnerability. It was published on September 5, 2026 and has a CVSS 3.1 base score of 8.3 (HIGH).

This vulnerability has a CVSS 3.1 base score of 8.3, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

YesWiki is a wiki system written in PHP. From version 4.6.2 to before version 4.6.6, the POST /api/forms/{formId}/actor/inbox route - exposed publicly with acl:"public" - accepts an HTTP Signature header whose keyId parameter is a URL. HttpSignatureService::verifySignature() parses the header and immediately makes a server-side HTTP GET to that URL, before any cryptographic verification or URL validation. An unauthenticated remote attacker can therefore make YesWiki issue arbitrary outbound HTTP requests to any host the server can reach - internal services, cloud-metadata endpoints (169.254.169.254), intranet-only admin panels, etc. - and read enough back via timing and error-message oracles to scan ports, enumerate services, and (on a real cloud instance) reach IAM metadata. The only deployment-side precondition is that ActivityPub be enabled on at least one Bazar form. This issue has been patched in version 4.6.6.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2026-52769?

CVE-2026-52769 is a high-severity vulnerability. It was published on September 5, 2026 and has a CVSS 3.1 base score of 8.3 (HIGH).

How severe is CVE-2026-52769?

This vulnerability has a CVSS 3.1 base score of 8.3, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-52769?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-52769?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-52769 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
Watch the demo →