Menu

Star on GitHub · 3.4k

CVE-2026-54597

8.3 · HIGH

ITFlow provides an IT documentation, ticketing and accounting system for small managed service providers.

Published Sep 17, 2026CWE-89EPSS 0.43%

Overview

CVE-2026-54597 is a high-severity vulnerability. It was published on September 17, 2026 and has a CVSS 3.1 base score of 8.3 (HIGH).

This vulnerability has a CVSS 3.1 base score of 8.3, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

ITFlow provides an IT documentation, ticketing and accounting system for small managed service providers. Prior to version 26.07, an authenticated user with module_support write permission and access to a credential record can perform time-based blind SQL injection through the expires parameter of the share_generate_link handler in agent/ajax.php. sanitizeInput applies string-context escaping, but expires is inserted unquoted into the item_expire_at MySQL INTERVAL expression, allowing a crafted expression and interval unit to execute conditional database queries whose results are inferred from response delays. This can expose password hashes, SMTP credentials, API keys, encrypted vault data, and database metadata and support administrative takeover after credential cracking. This issue is fixed in version 26.07.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2026-54597?

CVE-2026-54597 is a high-severity vulnerability. It was published on September 17, 2026 and has a CVSS 3.1 base score of 8.3 (HIGH).

How severe is CVE-2026-54597?

This vulnerability has a CVSS 3.1 base score of 8.3, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-54597?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-54597?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-54597 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
Watch the demo →