Menu

Star on GitHub · 3.4k

CVE-2026-54710

8.8 · HIGH

FreePBX is an open source IP PBX.

Published Sep 28, 2026sangomaCWE-20EPSS 0.51%

Overview

CVE-2026-54710 is a high-severity vulnerability affecting sangoma freepbx. It was published on September 28, 2026 and has a CVSS 3.1 base score of 8.8 (HIGH).

This vulnerability has a CVSS 3.1 base score of 8.8, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

FreePBX is an open source IP PBX. Prior to versions 16.0.40 and 17.0.7, a critical remote code execution (RCE) vulnerability exists in the superfecta module due to unsafe inclusion of arbitrary PHP files, allowing authenticated attackers to execute arbitrary PHP code on the server with the privileges of the web server user. Authentication with a known username is required. The vulnerability is rooted in the options and save_options cases in the Superfecta module's AJAX handler. The code dynamically includes PHP files from the sources/ directory based on user-supplied input. This allows an attacker to execute arbitrary code when combined with arbitrary directory creation (e.g., via the backup module) and file uploads that reveal full paths (e.g., via the soundlang module). This issue has been patched in versions 16.0.40 and 17.0.7.

Remediation

Check the references section for vendor advisories and patches from sangoma. Update freepbx to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
sangomafreepbx>= 16.0, < 16.0.40Affected

Frequently asked questions

What is CVE-2026-54710?

CVE-2026-54710 is a high-severity vulnerability affecting sangoma freepbx. It was published on September 28, 2026 and has a CVSS 3.1 base score of 8.8 (HIGH).

How severe is CVE-2026-54710?

This vulnerability has a CVSS 3.1 base score of 8.8, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-54710?

Check the references section for vendor advisories and patches from sangoma. Update freepbx to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-54710?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-54710 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
Watch the demo →