Menu

Star on GitHub · 3.4k

CVE-2026-55233

7.5 · HIGH

OpenResty is a high performance web platform.

Published Jul 10, 2026openrestyCWE-787EPSS 0.49%

Overview

CVE-2026-55233 is a high-severity vulnerability affecting openresty openresty. It was published on July 10, 2026 and has a CVSS 3.1 base score of 7.5 (HIGH).

This vulnerability has a CVSS 3.1 base score of 7.5, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

OpenResty is a high performance web platform. From 1.29.2.1 to before 1.29.2.5, an out-of-bounds write vulnerability exists in the upstream PROXY protocol v2 implementation. When OpenResty is configured to send PROXY protocol version 2 headers to upstream servers, constructing the header in the stream proxy protocol v2 patch can write beyond the bounds of the allocated buffer, causing the worker process to crash and resulting in a denial of service. Only configurations that explicitly enable PROXY protocol v2 for upstream connections are impacted. This issue is fixed in version 1.29.2.5.

Remediation

Check the references section for vendor advisories and patches from openresty. Update openresty to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
openrestyopenresty>= 1.29.2.1, < 1.29.2.5Affected

Frequently asked questions

What is CVE-2026-55233?

CVE-2026-55233 is a high-severity vulnerability affecting openresty openresty. It was published on July 10, 2026 and has a CVSS 3.1 base score of 7.5 (HIGH).

How severe is CVE-2026-55233?

This vulnerability has a CVSS 3.1 base score of 7.5, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-55233?

Check the references section for vendor advisories and patches from openresty. Update openresty to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-55233?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-55233 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
Watch the demo →