Menu

Star on GitHub · 3.4k

CVE-2026-55467

2.5 · LOW

OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems.

Published Oct 15, 2026openprintingCWE-93EPSS 0.18%

Overview

CVE-2026-55467 is a low-severity vulnerability affecting openprinting cups. It was published on October 15, 2026 and has a CVSS 3.1 base score of 2.5 (LOW).

This vulnerability has a CVSS 3.1 base score of 2.5, rated LOW. It requires local or adjacent network access to exploit. Some level of privileges is required for exploitation.

Technical description

OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. Prior to 2.4.20, the cupsdCreateJob option-string builder in scheduler/job.c maps attacker-controlled destination-uri and pre-dial-string values from a configured fax queue to the phone and faxPrefix options. Unlike ordinary IPP job attributes, these mapped fax values bypass the control-character sanitizer and are copied directly into the filter options argument. A user permitted to submit a job can therefore inject control characters into the downstream option stream. The reporter states that a downstream fax filter passing these values to a shell or modem command could execute code as lp, while the maintainer states that CUPS has no confidentiality or integrity impact because the only known code-executing filter is optional Foomatic and addressed separately, leaving possible disruption of the affected queue. This issue is fixed in version 2.4.20.

Remediation

Check the references section for vendor advisories and patches from openprinting. Update cups to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
openprintingcups>= 0, < 2.4.20Affected

Frequently asked questions

What is CVE-2026-55467?

CVE-2026-55467 is a low-severity vulnerability affecting openprinting cups. It was published on October 15, 2026 and has a CVSS 3.1 base score of 2.5 (LOW).

How severe is CVE-2026-55467?

This vulnerability has a CVSS 3.1 base score of 2.5, rated LOW. It requires local or adjacent network access to exploit. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-55467?

Check the references section for vendor advisories and patches from openprinting. Update cups to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-55467?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-55467 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related LOW CVEs from 2026

View all
Watch the demo →