Menu

Star on GitHub · 3.4k

CVE-2026-55470

7.5 · HIGH

HAPI FHIR is a complete implementation of the HL7 FHIR standard for healthcare interoperability in Java.

Published Jul 8, 2026hapifhirCWE-1333EPSS 0.68%

Overview

CVE-2026-55470 is a high-severity vulnerability affecting hapifhir hl7_fhir_core. It was published on July 8, 2026 and has a CVSS 3.1 base score of 7.5 (HIGH).

This vulnerability has a CVSS 3.1 base score of 7.5, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

HAPI FHIR is a complete implementation of the HL7 FHIR standard for healthcare interoperability in Java. Prior to 6.9.10, the fix for CVE-2026-45367 incompletely patched the DSTU2 module, leaving FHIRPathEngine.matches() in org.hl7.fhir.dstu2/utils/FHIRPathEngine.java to call raw String.matches(sw) without RegexTimeout protection while replaceMatches() was updated, allowing an unauthenticated attacker to trigger catastrophic regex backtracking and exhaust server CPU. This issue is fixed in version 6.9.10.

Remediation

Check the references section for vendor advisories and patches from hapifhir. Update hl7_fhir_core to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
hapifhirhl7_fhir_core>= 0, < 6.9.10Affected

Frequently asked questions

What is CVE-2026-55470?

CVE-2026-55470 is a high-severity vulnerability affecting hapifhir hl7_fhir_core. It was published on July 8, 2026 and has a CVSS 3.1 base score of 7.5 (HIGH).

How severe is CVE-2026-55470?

This vulnerability has a CVSS 3.1 base score of 7.5, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-55470?

Check the references section for vendor advisories and patches from hapifhir. Update hl7_fhir_core to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-55470?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-55470 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
Watch the demo →