Menu

Star on GitHub · 3.4k

CVE-2026-55562

9.0 · CRITICAL

Cronicle is a multi-server task scheduler and runner, with a web based front-end UI.

Published Oct 13, 2026CWE-79EPSS 0.46%

Overview

CVE-2026-55562 is a critical-severity vulnerability. It was published on October 13, 2026 and has a CVSS 3.1 base score of 9.0 (CRITICAL).

This vulnerability has a CVSS 3.1 base score of 9.0, rated CRITICAL. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

Cronicle is a multi-server task scheduler and runner, with a web based front-end UI. Prior to 0.9.119, the administrator Activity Log in htdocs/js/pages/admin/Activity.js concatenates the attacker-controlled item.user.full_name value into HTML without applying encode_entities and inserts the result through this.div.html. The bundled pixl-server-user input filter can be bypassed by a tag containing a line break because its regular expression does not match newlines. An authenticated non-administrator can update the attacker's own name through /api/user/update using a valid session and current password; when free_accounts is enabled, an anonymous attacker can instead plant the name during self-registration. The stored name executes script in an administrator's session when the Activity Log is opened, enabling administrator takeover and subsequent command execution through privileged Cronicle features. This issue is fixed in version 0.9.119.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2026-55562?

CVE-2026-55562 is a critical-severity vulnerability. It was published on October 13, 2026 and has a CVSS 3.1 base score of 9.0 (CRITICAL).

How severe is CVE-2026-55562?

This vulnerability has a CVSS 3.1 base score of 9.0, rated CRITICAL. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-55562?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-55562?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-55562 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related CRITICAL CVEs from 2026

View all
Watch the demo →