Menu

Star on GitHub · 3.4k

CVE-2026-57488

7.1 · HIGH

pupnp is an SDK for development of UPnP device and control point applications.

Published Oct 16, 2026pupnp_projectCWE-190EPSS 0.33%

Overview

CVE-2026-57488 is a high-severity vulnerability affecting pupnp_project pupnp. It was published on October 16, 2026 and has a CVSS 3.1 base score of 7.1 (HIGH).

This vulnerability has a CVSS 3.1 base score of 7.1, rated HIGH. It requires local or adjacent network access to exploit. No authentication or special privileges are required for exploitation.

Technical description

pupnp is an SDK for development of UPnP device and control point applications. Prior to 2.0.2, raw_to_int in upnp/src/genlib/net/http/httpparser.c parses Content-Length with strtol and casts the resulting long to a 32-bit int before the caller stores it as unsigned int. On LP64 systems, values greater than INT_MAX can truncate or wrap, so the HTTP parser can accept a body length different from the declared value. A remote adjacent-network peer can use the resulting parser disagreement to leave bytes to be interpreted as another request in persistent or proxied contexts, or can make a worker wait for an extremely large body and cause denial of service. This issue is fixed in 2.0.2.

Remediation

Check the references section for vendor advisories and patches from pupnp_project. Update pupnp to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
pupnp_projectpupnp>= 0, < 2.0.2Affected

Frequently asked questions

What is CVE-2026-57488?

CVE-2026-57488 is a high-severity vulnerability affecting pupnp_project pupnp. It was published on October 16, 2026 and has a CVSS 3.1 base score of 7.1 (HIGH).

How severe is CVE-2026-57488?

This vulnerability has a CVSS 3.1 base score of 7.1, rated HIGH. It requires local or adjacent network access to exploit. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-57488?

Check the references section for vendor advisories and patches from pupnp_project. Update pupnp to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-57488?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-57488 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
Watch the demo →