Menu

Star on GitHub · 3.4k

CVE-2026-59245

8.1 · HIGH

In the Apache Airflow FAB auth manager, a DAG whose `dag_id` is `DAGs` collided with the global all-DAGs permission resource name produced by `resource_name()`, so a user granted per-DAG `access_co…

Published Jul 13, 2026apacheCWE-269EPSS 0.60%

Overview

CVE-2026-59245 is a high-severity vulnerability affecting apache apache-airflow-providers-fab. It was published on July 13, 2026 and has a CVSS 3.1 base score of 8.1 (HIGH).

This vulnerability has a CVSS 3.1 base score of 8.1, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

In the Apache Airflow FAB auth manager, a DAG whose `dag_id` is `DAGs` collided with the global all-DAGs permission resource name produced by `resource_name()`, so a user granted per-DAG `access_control` on that one DAG was silently granted the global all-DAGs permission (privilege escalation). The escalation triggers when a DAG named `DAGs` exists and a lower-privileged user is given per-DAG access to it, granting that user read/edit access to every DAG. Users are advised to upgrade to `apache-airflow-providers-fab` 3.7.2 or later, which disambiguates the resource-name collision.

Remediation

Check the references section for vendor advisories and patches from apache. Update apache-airflow-providers-fab to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
apacheapache-airflow-providers-fab>= 0, < 3.7.2Affected

Frequently asked questions

What is CVE-2026-59245?

CVE-2026-59245 is a high-severity vulnerability affecting apache apache-airflow-providers-fab. It was published on July 13, 2026 and has a CVSS 3.1 base score of 8.1 (HIGH).

How severe is CVE-2026-59245?

This vulnerability has a CVSS 3.1 base score of 8.1, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-59245?

Check the references section for vendor advisories and patches from apache. Update apache-airflow-providers-fab to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-59245?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-59245 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
Watch the demo →