Menu

Star on GitHub · 3.4k

CVE-2026-63686

7.5 · HIGH

A NULL pointer dereference in mod_xml2enc in Apache Software Foundation Apache HTTP Server before 2.4.69 on all platforms allows an untrusted backend server to cause a denial of service via a proxi…

Published Oct 1, 2026apacheCWE-476EPSS 0.46%

Overview

CVE-2026-63686 is a high-severity vulnerability affecting apache http_server. It was published on October 1, 2026 and has a CVSS 3.1 base score of 7.5 (HIGH).

This vulnerability has a CVSS 3.1 base score of 7.5, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

A NULL pointer dereference in mod_xml2enc in Apache Software Foundation Apache HTTP Server before 2.4.69 on all platforms allows an untrusted backend server to cause a denial of service via a proxied response with a charset whose conversion partially succeeds then fails.

Users are recommended to upgrade to version 2.4.69, which fixes this issue.

Remediation

Check the references section for vendor advisories and patches from apache. Update http_server to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
apachehttp_server>= 2.4.0, < 2.4.69Affected

Frequently asked questions

What is CVE-2026-63686?

CVE-2026-63686 is a high-severity vulnerability affecting apache http_server. It was published on October 1, 2026 and has a CVSS 3.1 base score of 7.5 (HIGH).

How severe is CVE-2026-63686?

This vulnerability has a CVSS 3.1 base score of 7.5, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-63686?

Check the references section for vendor advisories and patches from apache. Update http_server to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-63686?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-63686 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
Watch the demo →