Menu

Star on GitHub · 3.4k

CVE-2026-65390

8.8 · HIGH

An integer overflow was addressed with improved input validation.

Published Sep 14, 2026appleCWE-190EPSS 0.41%

Overview

CVE-2026-65390 is a high-severity vulnerability affecting apple safari. It was published on September 14, 2026 and has a CVSS 3.1 base score of 8.8 (HIGH).

This vulnerability has a CVSS 3.1 base score of 8.8, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

An integer overflow was addressed with improved input validation. This issue is fixed in Safari 26.6.1, iOS 26.6.1 and iPadOS 26.6.1, macOS Tahoe 26.6.2, tvOS 27, visionOS 27, watchOS 27. Processing maliciously crafted web content may lead to memory corruption.

Remediation

Check the references section for vendor advisories and patches from apple. Update safari to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
applesafari>= 0, < 26.6.1Affected
appleipados>= 0, < 26.6.1Affected
appleiphone_os>= 0, < 26.6.1Affected
applemacos>= 0, < 26.6.2Affected
appletvos>= 0, < 27.0Affected
applevisionos>= 0, < 27.0Affected
applewatchos>= 0, < 27.0Affected

Frequently asked questions

What is CVE-2026-65390?

CVE-2026-65390 is a high-severity vulnerability affecting apple safari. It was published on September 14, 2026 and has a CVSS 3.1 base score of 8.8 (HIGH).

How severe is CVE-2026-65390?

This vulnerability has a CVSS 3.1 base score of 8.8, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-65390?

Check the references section for vendor advisories and patches from apple. Update safari to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-65390?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-65390 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
Watch the demo →