Menu

Star on GitHub · 3.4k

CVE-2026-66080

4.9 · MEDIUM

RabbitMQ is a messaging and streaming broker.

Published Sep 23, 2026broadcomCWE-770EPSS 0.32%

Overview

CVE-2026-66080 is a medium-severity vulnerability affecting broadcom rabbitmq_server. It was published on September 23, 2026 and has a CVSS 3.1 base score of 4.9 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 4.9, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

RabbitMQ is a messaging and streaming broker. Prior to versions 4.1.11, 4.2.6, and 4.3.0, validate_partitions only checks that the requested partition count is at least 1, with no upper bound. A large count such as lists:seq(0, 500000000) allocates roughly 8GB. Preconditions include The rabbitmq_stream_management plugin must be enabled. The caller needs the management tag and access to the target vhost.. This issue is fixed in versions 4.1.11, 4.2.6, and 4.3.0.

Remediation

Check the references section for vendor advisories and patches from broadcom. Update rabbitmq_server to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
broadcomrabbitmq_server>= 4.1.0, < 4.1.11Affected

Frequently asked questions

What is CVE-2026-66080?

CVE-2026-66080 is a medium-severity vulnerability affecting broadcom rabbitmq_server. It was published on September 23, 2026 and has a CVSS 3.1 base score of 4.9 (MEDIUM).

How severe is CVE-2026-66080?

This vulnerability has a CVSS 3.1 base score of 4.9, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-66080?

Check the references section for vendor advisories and patches from broadcom. Update rabbitmq_server to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-66080?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-66080 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2026

View all
Watch the demo →