Menu

Star on GitHub · 3.4k

CVE-2026-67404

7.4 · HIGH

RabbitMQ is a messaging and streaming broker.

Published Sep 23, 2026broadcomCWE-295EPSS 0.20%

Overview

CVE-2026-67404 is a high-severity vulnerability affecting broadcom rabbitmq_server. It was published on September 23, 2026 and has a CVSS 3.1 base score of 7.4 (HIGH).

This vulnerability has a CVSS 3.1 base score of 7.4, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0, When no CA bundle is available, ssl_options/1 falls back to [{verify, verify_none}] with no warning. An attacker in a man-in-the-middle position can forge the JWKS response, which leads the broker to accept arbitrary JWTs. Preconditions include The OAuth2 plugin must be in use with no cacertfile configured and the OS CA bundle empty or unreadable (for example, in a minimal container), and the attacker must hold a network man-in-the-middle position.. This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0.

Remediation

Check the references section for vendor advisories and patches from broadcom. Update rabbitmq_server to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
broadcomrabbitmq_server>= 3.13.0, < 3.13.15Affected

Frequently asked questions

What is CVE-2026-67404?

CVE-2026-67404 is a high-severity vulnerability affecting broadcom rabbitmq_server. It was published on September 23, 2026 and has a CVSS 3.1 base score of 7.4 (HIGH).

How severe is CVE-2026-67404?

This vulnerability has a CVSS 3.1 base score of 7.4, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-67404?

Check the references section for vendor advisories and patches from broadcom. Update rabbitmq_server to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-67404?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-67404 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
Watch the demo →