Menu

Star on GitHub · 3.5k

CVE-2026-77254

9.1 · CRITICAL

MCP Atlassian is a Model Context Protocol (MCP) server for Atlassian products (Confluence and Jira).

Published Sep 22, 2026mcp-atlassianCWE-306EPSS 0.62%

Overview

CVE-2026-77254 is a critical-severity vulnerability affecting mcp-atlassian mcp_atlassian. It was published on September 22, 2026 and has a CVSS 3.1 base score of 9.1 (CRITICAL).

This vulnerability has a CVSS 3.1 base score of 9.1, rated CRITICAL. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

MCP Atlassian is a Model Context Protocol (MCP) server for Atlassian products (Confluence and Jira). Prior to 0.22.0, requests to the HTTP MCP endpoint without a per-user identity are allowed to reach tool handlers, which then use globally configured Jira or Confluence credentials. A network caller can perform operations with the operator account's permissions unless the deployment has an independent authentication boundary. The advisory traces the vulnerable input and processing flow through streamable-http, UserTokenMiddleware, _get_fetcher, and global credentials, which identify the affected entry points, controls, and code paths. This issue is fixed in version 0.22.0.

Remediation

Check the references section for vendor advisories and patches from mcp-atlassian. Update mcp_atlassian to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
mcp-atlassianmcp_atlassian>= 0, < 0.22.0Affected

Frequently asked questions

What is CVE-2026-77254?

CVE-2026-77254 is a critical-severity vulnerability affecting mcp-atlassian mcp_atlassian. It was published on September 22, 2026 and has a CVSS 3.1 base score of 9.1 (CRITICAL).

How severe is CVE-2026-77254?

This vulnerability has a CVSS 3.1 base score of 9.1, rated CRITICAL. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-77254?

Check the references section for vendor advisories and patches from mcp-atlassian. Update mcp_atlassian to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-77254?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-77254 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related CRITICAL CVEs from 2026

View all
CyberStrike v2 is here — more intelligence, greater reach