Menu

Star on GitHub · 3.4k

CVE-2026-80312

8.2 · HIGH

Improper Authentication vulnerability in Apache Camel OAuth component.

Published Oct 19, 2026CWE-287EPSS 0.57%

Overview

CVE-2026-80312 is a high-severity vulnerability. It was published on October 19, 2026 and has a CVSS 3.1 base score of 8.2 (HIGH).

This vulnerability has a CVSS 3.1 base score of 8.2, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

Improper Authentication vulnerability in Apache Camel OAuth component.

This issue affects Apache Camel: from 4.11.0 before 4.18.5, from 4.19.0 before 4.22.1.

The camel-oauth processors that guard a route did not stop the exchange when authentication could not be completed. Where a failure to establish an authenticated session should have terminated routing and returned an error to the caller, the processors fell through and returned control to the route, so the request continued to the protected endpoint as though authentication had succeeded. The effect is a fail-open authentication guard: an unauthenticated caller reached whatever the route did next. The condition is reached on the ordinary request path of a route configured to require OAuth, and needs no special configuration or prior access on the caller's part.

Upgrade to Apache Camel 4.23.0, which fixes the issue. Users on the 4.18.x LTS releases stream should upgrade to 4.18.5. Users on the 4.22.x LTS releases stream sh

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2026-80312?

CVE-2026-80312 is a high-severity vulnerability. It was published on October 19, 2026 and has a CVSS 3.1 base score of 8.2 (HIGH).

How severe is CVE-2026-80312?

This vulnerability has a CVSS 3.1 base score of 8.2, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-80312?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-80312?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-80312 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
Watch the demo →