Menu

Star on GitHub · 3.4k

CVE-2026-82310

7.2 · HIGH

Apache Airflow FAB provider: deactivating a user account does not stop tokens issued to that account before deactivation.

Published Sep 16, 2026apacheCWE-613EPSS 1.00%

Overview

CVE-2026-82310 is a high-severity vulnerability affecting apache apache-airflow-providers-fab. It was published on September 16, 2026 and has a CVSS 3.1 base score of 7.2 (HIGH).

This vulnerability has a CVSS 3.1 base score of 7.2, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

Apache Airflow FAB provider: deactivating a user account does not stop tokens issued to that account before deactivation. Password authentication correctly rejects the disabled account, but the Core API continues to accept an existing, unexpired token naming it, and lets that token mint a replacement — so the account keeps its role-scoped access indefinitely after an administrator has disabled it. The user replays their own legitimate credential; no signature forgery or privilege escalation is involved, and the access stays within the roles the account already held.

Affects deployments using Airflow 3 with the FAB auth manager and Core API token authentication, where an administrator deactivates an account whose row remains in the database and whose previously issued token has not expired. The trigger is administrative deactivation as a containment action, which silently fails to contain.

Users of apache-airflow-providers-fab are recommended to upgrade to version 3.9.0 or later, whic

Remediation

Check the references section for vendor advisories and patches from apache. Update apache-airflow-providers-fab to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
apacheapache-airflow-providers-fab>= 2.0.0, < 3.9.0Affected

Frequently asked questions

What is CVE-2026-82310?

CVE-2026-82310 is a high-severity vulnerability affecting apache apache-airflow-providers-fab. It was published on September 16, 2026 and has a CVSS 3.1 base score of 7.2 (HIGH).

How severe is CVE-2026-82310?

This vulnerability has a CVSS 3.1 base score of 7.2, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-82310?

Check the references section for vendor advisories and patches from apache. Update apache-airflow-providers-fab to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-82310?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-82310 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
Watch the demo →