Menu

Star on GitHub · 3.4k

CVE-2026-83745

Memory allocation with excessive size value, Improper handling of length parameter inconsistency vulnerability in Apache Thrift  nodejs and D lang bindings.

Published Oct 2, 2026CWE-130EPSS 0.34%

Overview

CVE-2026-83745 is a known-severity vulnerability. It was published on October 2, 2026.

Technical description

Memory allocation with excessive size value, Improper handling of length parameter inconsistency vulnerability in Apache Thrift 

nodejs and D lang bindings.

Both bindings' WebSocket server transports read the payload length out of the frame header and allocate that many bytes immediately, without checking that the bytes have arrived. A single ~14-byte frame therefore commits as much memory as it cares to declare -- measured at 513 MiB against the Node.js server and 2 GiB against the D transport -- and in the Node.js case the connection is left open afterwards, so the frame can simply be sent again.

This issue affects Apache Thrift before 0.25.0.

Users are recommended to upgrade to version 0.25.0, which fixes the issue.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2026-83745?

CVE-2026-83745 is a known-severity vulnerability. It was published on October 2, 2026.

How severe is CVE-2026-83745?

CVSS score information is not yet available for this vulnerability. Check back as the CVE record is updated by NVD analysts.

How do I fix or remediate CVE-2026-83745?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-83745?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-83745 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

CyberStrike v2 is here — more intelligence, greater reach