CVE-2026-85313
4.3 · MEDIUMPermissive Cross-domain Policy with Untrusted Domains vulnerability in Apache Camel Jetty component.
Overview
CVE-2026-85313 is a medium-severity vulnerability. It was published on October 19, 2026 and has a CVSS 3.1 base score of 4.3 (MEDIUM).
This vulnerability has a CVSS 3.1 base score of 4.3, rated MEDIUM. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.
Technical description
Permissive Cross-domain Policy with Untrusted Domains vulnerability in Apache Camel Jetty component.
This issue affects Apache Camel: from 4.0.0 before 4.18.5, from 4.19.0 before 4.22.1.
Setting enableCORS on a Jetty endpoint installed Jetty's CrossOriginFilter with its stock defaults, which accept every origin and allow credentials. An operator asking for CORS therefore obtained a policy that lets a page on any origin make credentialed cross-origin requests to the endpoint and read the responses, without any indication that turning the option on had chosen an allow-all policy rather than an empty one to be filled in. This is the same defect class as the platform-http-vertx advisory published alongside it, in a different component.
Upgrade to Apache Camel 4.23.0, which fixes the issue. Users on the 4.18.x LTS releases stream should upgrade to 4.18.5. Users on the 4.22.x LTS releases stream should upgrade to 4.22.1. enableCORS no longer grants credentials to an origin the operator di
Remediation
Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.
How CyberStrike helps
Reason, not just scan
It reasons through your app's logic the way a human pentester would, so it finds flaws signature scanners miss.
Learn moreVerified findings
Every finding is proven exploitable before you see it, which cuts the false positives that bury real risk.
Learn moreAI-driven DAST and SAST
Probe running apps and read source from one engine, so issues are caught before and after they ship.
Learn moreOpen source
Read exactly how it tests and what it reports. CyberStrike is open source and in early access.
View the repo
Frequently asked questions
What is CVE-2026-85313?
CVE-2026-85313 is a medium-severity vulnerability. It was published on October 19, 2026 and has a CVSS 3.1 base score of 4.3 (MEDIUM).
How severe is CVE-2026-85313?
This vulnerability has a CVSS 3.1 base score of 4.3, rated MEDIUM. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.
How do I fix or remediate CVE-2026-85313?
Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.
How can CyberStrike help with CVE-2026-85313?
CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-85313 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.
Related MEDIUM CVEs from 2026
View all- 6.9CVE-2025-68933
Discourse is an open source discussion platform. In versions prior to 3.5.4, 2025.11.2, 2025.12.1, a
View details - 6.9CVE-2026-25210
In libexpat before 2.7.4, the doContent function does not properly determine the buffer size bufSize
View details - 6.9CVE-2026-24922
Buffer overflow vulnerability in the HDC module. Impact: Successful exploitation of this vulnerabili
View details - 6.9CVE-2026-28690
ImageMagick is free and open-source software used for editing and manipulating digital images. Prior
View details - 6.9CVE-2025-68482
A improper certificate validation vulnerability in Fortinet FortiAnalyzer 7.6.0 through 7.6.4, Forti
View details - 6.9CVE-2026-32041
OpenClaw versions prior to 2026.3.1 fail to properly handle authentication bootstrap errors during s
View details - 6.9CVE-2026-34530
File Browser is a file managing interface for uploading, deleting, previewing, renaming, and editing
View details - 6.9CVE-2026-28553
Vulnerability of improper permission control in the theme setting module. Impact: Successful exploit
View details - 6.9CVE-2026-40446
Access of resource using incompatible type ('type confusion') vulnerability in Samsung Open Source E
View details - 6.9CVE-2026-37980
A flaw was found in Keycloak, specifically in the organization selection login page. A remote attack
View details - 6.9CVE-2026-39963
Serendipity is a PHP-powered weblog engine. In versions 2.6-beta2 and below, the serendipity_setCoo
View details - 6.9CVE-2026-41253
In iTerm2 through 3.6.9, displaying a .txt file can cause code execution via DCS 2000p and OSC 135 d
View details
