Menu

Star on GitHub · 3.4k

CVE-2026-85985

5.4 · MEDIUM

MariaDB server is a community developed fork of MySQL server.

Published Oct 16, 2026mariadbCWE-862EPSS 0.45%

Overview

CVE-2026-85985 is a medium-severity vulnerability affecting mariadb mariadb. It was published on October 16, 2026 and has a CVSS 3.1 base score of 5.4 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 5.4, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

MariaDB server is a community developed fork of MySQL server. From 10.6.1 until 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2, the CONNECT engine plugin file-access UDFs json_file(), bson_file(), jfile_make(), bfile_make(), and jbin_file() are affected because each does not enforce FILE privilege or the secure_file_priv setting. A low-privileged attacker can trigger the issue by calling a CONNECT file-access UDF with a filesystem path, then invoke a CONNECT file-access UDF to access a filesystem path and read or write files that the database account is not authorized to access, subject to operating-system permissions. This issue is fixed in versions 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2.

Remediation

Check the references section for vendor advisories and patches from mariadb. Update mariadb to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
mariadbmariadb>= 10.6.1, < 10.6.28Affected

Frequently asked questions

What is CVE-2026-85985?

CVE-2026-85985 is a medium-severity vulnerability affecting mariadb mariadb. It was published on October 16, 2026 and has a CVSS 3.1 base score of 5.4 (MEDIUM).

How severe is CVE-2026-85985?

This vulnerability has a CVSS 3.1 base score of 5.4, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-85985?

Check the references section for vendor advisories and patches from mariadb. Update mariadb to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-85985?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-85985 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2026

View all
Watch the demo →