Menu

Star on GitHub · 3.4k

CVE-2026-86002

9.0 · CRITICAL

Dokku is a docker-powered platform as a service.

Published Oct 14, 2026CWE-95EPSS 0.56%

Overview

CVE-2026-86002 is a critical-severity vulnerability. It was published on October 14, 2026 and has a CVSS 3.1 base score of 9.0 (CRITICAL).

This vulnerability has a CVSS 3.1 base score of 9.0, rated CRITICAL. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

Dokku is a docker-powered platform as a service. In Dokku versions before 0.38.25, a user with app-level Dokku access and remote SSH access to execute docker-options commands can store arbitrary strings through the docker-options plugin, and those strings are later concatenated into DOCKER_ARGS and processed by Bash eval during build, deploy, or run operations. Shell command substitutions in the stored values are interpreted on the host, allowing arbitrary command execution with the privileges of the dokku operating-system user. This issue is fixed in version 0.38.25.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2026-86002?

CVE-2026-86002 is a critical-severity vulnerability. It was published on October 14, 2026 and has a CVSS 3.1 base score of 9.0 (CRITICAL).

How severe is CVE-2026-86002?

This vulnerability has a CVSS 3.1 base score of 9.0, rated CRITICAL. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-86002?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-86002?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-86002 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related CRITICAL CVEs from 2026

View all
Watch the demo →