Menu

Star on GitHub · 3.4k

CVE-2026-86035

8.5 · HIGH

Weblate is a web-based continuous localization platform used to manage software translations.

Published Sep 29, 2026CWE-78EPSS 0.46%

Overview

CVE-2026-86035 is a high-severity vulnerability. It was published on September 29, 2026 and has a CVSS 3.1 base score of 8.5 (HIGH).

This vulnerability has a CVSS 3.1 base score of 8.5, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

Weblate is a web-based continuous localization platform used to manage software translations. Weblate 4.11.1 through 2026.7.1 contains an argument-injection vulnerability in its Mercurial backend. Repository filenames beginning with - could be interpreted as Mercurial options instead of literal paths. An authenticated user with project-scoped component.edit permission could exploit this through a Mercurial-backed RESX component using the Update RESX files add-on. A later repository update could execute arbitrary commands with the privileges of the Weblate service account. This is a residual incomplete fix for CVE-2022-23915. This issue has been patched in version 2026.8.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2026-86035?

CVE-2026-86035 is a high-severity vulnerability. It was published on September 29, 2026 and has a CVSS 3.1 base score of 8.5 (HIGH).

How severe is CVE-2026-86035?

This vulnerability has a CVSS 3.1 base score of 8.5, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-86035?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-86035?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-86035 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
Watch the demo →