Menu

Star on GitHub · 3.4k

CVE-2026-86047

7.7 · HIGH

MariaDB server is a community developed fork of MySQL server.

Published Oct 16, 2026mariadbCWE-89EPSS 0.86%

Overview

CVE-2026-86047 is a high-severity vulnerability affecting mariadb mariadb. It was published on October 16, 2026 and has a CVSS 3.1 base score of 7.7 (HIGH).

This vulnerability has a CVSS 3.1 base score of 7.7, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

MariaDB server is a community developed fork of MySQL server. From 10.6.1 until 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2, SHOW CREATE SERVER, SHOW CREATE USER, and mariadb-dump are affected because each does not consistently quote identifiers and values when serializing SQL. A low-privileged attacker can trigger the issue when an attacker-created object with crafted identifiers or values is included in SHOW output or a dump, then create an object with crafted identifiers or values so generated SQL contains injected statements and execute attacker-injected SQL when the poisoned output is applied. This issue is fixed in versions 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2.

Remediation

Check the references section for vendor advisories and patches from mariadb. Update mariadb to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
mariadbmariadb>= 10.6.1, < 10.6.28Affected

Frequently asked questions

What is CVE-2026-86047?

CVE-2026-86047 is a high-severity vulnerability affecting mariadb mariadb. It was published on October 16, 2026 and has a CVSS 3.1 base score of 7.7 (HIGH).

How severe is CVE-2026-86047?

This vulnerability has a CVSS 3.1 base score of 7.7, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-86047?

Check the references section for vendor advisories and patches from mariadb. Update mariadb to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-86047?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-86047 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
Watch the demo →