Menu

Star on GitHub · 3.4k

CVE-2026-86358

6.5 · MEDIUM

Dell Update Package Framework, versions prior to 26.07.03, contains a Stack-based Buffer Overflow vulnerability.

Published Sep 16, 2026dellCWE-121EPSS 0.41%

Overview

CVE-2026-86358 is a medium-severity vulnerability affecting dell update_package_framework. It was published on September 16, 2026 and has a CVSS 3.1 base score of 6.5 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 6.5, rated MEDIUM. It requires local or adjacent network access to exploit. No authentication or special privileges are required for exploitation.

Technical description

Dell Update Package Framework, versions prior to 26.07.03, contains a Stack-based Buffer Overflow vulnerability. An unauthenticated attacker with adjacent network access could potentially exploit this vulnerability, leading to Remote execution.

Remediation

Check the references section for vendor advisories and patches from dell. Update update_package_framework to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
dellupdate_package_framework>= 0, < 26.07.03Affected

Frequently asked questions

What is CVE-2026-86358?

CVE-2026-86358 is a medium-severity vulnerability affecting dell update_package_framework. It was published on September 16, 2026 and has a CVSS 3.1 base score of 6.5 (MEDIUM).

How severe is CVE-2026-86358?

This vulnerability has a CVSS 3.1 base score of 6.5, rated MEDIUM. It requires local or adjacent network access to exploit. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-86358?

Check the references section for vendor advisories and patches from dell. Update update_package_framework to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-86358?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-86358 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2026

View all
Watch the demo →