Menu

Star on GitHub · 3.4k

CVE-2026-86466

8.1 · HIGH

Apache Airflow FAB provider: the Authentik OAuth path in the FAB auth manager does not validate the issuer or audience claims of the id_token it accepts.

Published Sep 16, 2026apacheCWE-346EPSS 0.37%

Overview

CVE-2026-86466 is a high-severity vulnerability affecting apache apache-airflow-providers-fab. It was published on September 16, 2026 and has a CVSS 3.1 base score of 8.1 (HIGH).

This vulnerability has a CVSS 3.1 base score of 8.1, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

Apache Airflow FAB provider: the Authentik OAuth path in the FAB auth manager does not validate the issuer or audience claims of the id_token it accepts. An attacker holding a token that the same Authentik identity provider minted for a different client application can present it to Airflow and be authenticated as the user it names, because the audience claim is never checked. Affects deployments using the FAB auth manager with Authentik OAuth where the same Authentik instance also serves other applications; the attacker needs a valid token for any of those other applications, not for Airflow.

CVE-2026-75156 corrected the same missing validation on the Azure AD path in this file; the Authentik path was left unchanged and is fixed here. Deployments that applied the CVE-2026-75156 fix and use Authentik must also upgrade for this one.

Users of apache-airflow-providers-fab are recommended to upgrade to version 3.9.0 or later, which fixes the issue.

Remediation

Check the references section for vendor advisories and patches from apache. Update apache-airflow-providers-fab to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
apacheapache-airflow-providers-fab>= 0, < 3.9.0Affected

Frequently asked questions

What is CVE-2026-86466?

CVE-2026-86466 is a high-severity vulnerability affecting apache apache-airflow-providers-fab. It was published on September 16, 2026 and has a CVSS 3.1 base score of 8.1 (HIGH).

How severe is CVE-2026-86466?

This vulnerability has a CVSS 3.1 base score of 8.1, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-86466?

Check the references section for vendor advisories and patches from apache. Update apache-airflow-providers-fab to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-86466?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-86466 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
Watch the demo →