CVE-2026-86472
4.8 · MEDIUMfast-uri is a dependency-free RFC 3986 URI parser for Node.js, used by Fastify and ajv.
Overview
CVE-2026-86472 is a medium-severity vulnerability. It was published on September 15, 2026 and has a CVSS 3.1 base score of 4.8 (MEDIUM).
This vulnerability has a CVSS 3.1 base score of 4.8, rated MEDIUM. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.
Technical description
fast-uri is a dependency-free RFC 3986 URI parser for Node.js, used by Fastify and ajv. In versions before 2.4.7, from 3.0.0 through 3.1.7, and from 4.0.0 through 4.1.4, fast-uri folds the host to lowercase before it percent-decodes the host, so a percent-encoded uppercase octet such as %41 decodes to a literal A that is never folded. For a scheme-relative reference such as //host there is no scheme, so the host canonicalization that would normally repair this does not run, and parse, normalize, and equal then disagree on the same host. An application that makes a case-sensitive host decision on fast-uri output, for example a host allowlist or denylist that compares the parsed host or uses equal, can be steered past the check with a percent-encoded uppercase octet, and because hostnames are case-insensitive in DNS and HTTP the evading spelling still reaches the host the check meant to gate. The issue is fixed in fast-uri 2.4.7, 3.1.8, and 4.1.5, and users should upgrade to one of those
Remediation
Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.
How CyberStrike helps
Reason, not just scan
It reasons through your app's logic the way a human pentester would, so it finds flaws signature scanners miss.
Learn moreVerified findings
Every finding is proven exploitable before you see it, which cuts the false positives that bury real risk.
Learn moreAI-driven DAST and SAST
Probe running apps and read source from one engine, so issues are caught before and after they ship.
Learn moreOpen source
Read exactly how it tests and what it reports. CyberStrike is open source and in early access.
View the repo
Frequently asked questions
What is CVE-2026-86472?
CVE-2026-86472 is a medium-severity vulnerability. It was published on September 15, 2026 and has a CVSS 3.1 base score of 4.8 (MEDIUM).
How severe is CVE-2026-86472?
This vulnerability has a CVSS 3.1 base score of 4.8, rated MEDIUM. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.
How do I fix or remediate CVE-2026-86472?
Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.
How can CyberStrike help with CVE-2026-86472?
CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-86472 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.
Related MEDIUM CVEs from 2026
View all- 6.9CVE-2025-68933
Discourse is an open source discussion platform. In versions prior to 3.5.4, 2025.11.2, 2025.12.1, a
View details - 6.9CVE-2026-25210
In libexpat before 2.7.4, the doContent function does not properly determine the buffer size bufSize
View details - 6.9CVE-2026-24922
Buffer overflow vulnerability in the HDC module. Impact: Successful exploitation of this vulnerabili
View details - 6.9CVE-2026-28690
ImageMagick is free and open-source software used for editing and manipulating digital images. Prior
View details - 6.9CVE-2025-68482
A improper certificate validation vulnerability in Fortinet FortiAnalyzer 7.6.0 through 7.6.4, Forti
View details - 6.9CVE-2026-32041
OpenClaw versions prior to 2026.3.1 fail to properly handle authentication bootstrap errors during s
View details - 6.9CVE-2026-34530
File Browser is a file managing interface for uploading, deleting, previewing, renaming, and editing
View details - 6.9CVE-2026-28553
Vulnerability of improper permission control in the theme setting module. Impact: Successful exploit
View details - 6.9CVE-2026-40446
Access of resource using incompatible type ('type confusion') vulnerability in Samsung Open Source E
View details - 6.9CVE-2026-37980
A flaw was found in Keycloak, specifically in the organization selection login page. A remote attack
View details - 6.9CVE-2026-39963
Serendipity is a PHP-powered weblog engine. In versions 2.6-beta2 and below, the serendipity_setCoo
View details - 6.9CVE-2026-41253
In iTerm2 through 3.6.9, displaying a .txt file can cause code execution via DCS 2000p and OSC 135 d
View details
