Menu

Star on GitHub · 3.4k

CVE-2026-88016

7.1 · HIGH

rclone is a command-line program to sync files and directories to and from different cloud storage providers.

Published Sep 10, 2026rcloneCWE-59EPSS 0.19%

Overview

CVE-2026-88016 is a high-severity vulnerability affecting rclone rclone. It was published on September 10, 2026 and has a CVSS 3.1 base score of 7.1 (HIGH).

This vulnerability has a CVSS 3.1 base score of 7.1, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

rclone is a command-line program to sync files and directories to and from different cloud storage providers. Prior to 1.75.1, when backend/local runs with --links, a source .rclonelink object can plant a symlink in the destination and later directory metadata is applied through that path. MkdirMetadata, writeMetadataToFile, and setTimes operate when Directory.translatedLink=false, so os.Chown, os.Chmod, os.Chtimes, and birth-time handling can bypass os.Root confinement and follow the symlink. An attacker controlling source contents can therefore apply selected ownership, permissions, modification times, or birth times to a file or directory outside the destination, with --metadata required for chmod and chown while modification time is applied by the normal directory workflow. This issue is fixed in version 1.75.1.

Remediation

Check the references section for vendor advisories and patches from rclone. Update rclone to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
rclonerclone>= 0, < 1.75.1Affected

Frequently asked questions

What is CVE-2026-88016?

CVE-2026-88016 is a high-severity vulnerability affecting rclone rclone. It was published on September 10, 2026 and has a CVSS 3.1 base score of 7.1 (HIGH).

How severe is CVE-2026-88016?

This vulnerability has a CVSS 3.1 base score of 7.1, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-88016?

Check the references section for vendor advisories and patches from rclone. Update rclone to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-88016?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-88016 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
Watch the demo →